Boutique Cinema 4D
Affichage des résultats 1 à 5 sur 5

Discussion: Probleme de modélisation avec l'outil sweep

  1. #1
    Touriste Avatar de Triphon75
    Date d'inscription
    mars 2019
    C4D version
    Autre
    OS
    mac ox C4D R23
    Messages
    15

    Question Probleme de modélisation avec l'outil sweep

    Salut tout le monde !
    Je continue mon apprentissage de C4D et pour ça j'essaye de refaire une animation que j'avais fait en modélisation procédurale sur Modo il y a un certain temps. En gros ce sont des demi-cylindres qui se séparent les uns des autres par une surface courbée de la même section.

    La méthodologie que j'ai trouvé sur C4D est la suivante :
    -créer un arc de cercle qui va définir le trajet de mon mouvement.
    - créer une section qui va venir se propager le long de ma courbe en se servant de l'outil Swepp.
    - créer mes deux demi-cylindres et les positionner chacun au bout de mon arc de cercle avec l'outil align to spline
    Comme ça me suffit d'animer les paramètres start et End Angle de ma courbe pour pouvoir piloter globalement l'animation que je souhaite.

    Mais là je bloque sur un truc et j'aurais besoin de vos lumière, s'il vous plait,car je n'obtiens pas précisément ce que je souhaite
    1/Il y a un très léger décalage en rotation des mes demi-cylindres par rapport aux deux terminaisons de la forme que j'ai obtenu avec le sweep. (voir copie d'écran )
    Est ce que j'ai fait une erreur quelque par ?
    Y'a-t-il une autre méthode pour faire ça ou une solution de contournement (à part d'utiliser l'outil connect et soudure qui est pour moi un peu une méthode de brute).
    2/le second problème rencontré est qu'un de mes demi-cylindres pivote de 90 uniquement le start angle de ma courbe est à 0 °.
    ça doit être un souci de UpVector que je sais pas résoudre .

    Un grand merci d'avance pour vos réponses d'experts de C4D.
    Cliquez sur l'image pour la voir en taille réelle 

Nom : 		Capture d’écran 2021-01-20 à 14.47.51.png 
Affichages :	3 
Taille :		121,3 Ko 
ID : 			23675
    Fichiers attachés Fichiers attachés
    Dernière modification par Triphon75 ; 20/01/2021 à 15h31.

  2. #2
    Gourou Avatar de lenogre
    Date d'inscription
    août 2002
    C4D version
    R20 Studio
    OS
    OS 10.12.6
    Messages
    4 307
    Tu as 3 objets qui ne sont pas tout à fait parfaitement raccord.
    L'idée est de ne faire qu'un seul objet.
    J'ai supprimé les couvercles du sweep et les "couvercles des arrondis.
    J'ai mis les 3 objets dans un objet Connecteur et augmenté la tolérance : les objets se soudent automatiquement. Fin du problème.
    Dans le cadre d'une animation, je n'ai pas vérifié comment se comportait l'objet.
    Fichiers attachés Fichiers attachés
    Tout ce que j'écris est à prendre au 15e degré. Car comme dit le proverbe chinois : Quand le dragon d'or, le ragondin ; voilà qui devrait faire taire les critiques et me mettre à l'abri d'attaques frontales.

  3. #3
    Touriste Avatar de Triphon75
    Date d'inscription
    mars 2019
    C4D version
    Autre
    OS
    mac ox C4D R23
    Messages
    15
    Merci pour ta réponse, mais apparemment je ne peux pas télécharger les pièces jointes. Est ce qu'un admin pourrais règler ça svp ?

  4. #4
    Vieux Croûton Avatar de Aurety
    Date d'inscription
    juillet 2002
    C4D version
    R17 Studio
    OS
    Mac
    Messages
    14 461
    Billets dans le blog
    3
    Réessaie, je crois qu'on peut télécharger à partir de 10 messages, je t'ai mis à 11, dis-moi si ça marche..
    Franchement, je prendrais plutôt le spline wrap pour faire ce genre de job, tu as toutes les options du sweep et plus encore.. et tu as aussi l'utilisation des fields pour d'autres effets.
    kenavo !! // Pinterest KAMIGAZ®

  5. #5
    Touriste Avatar de Triphon75
    Date d'inscription
    mars 2019
    C4D version
    Autre
    OS
    mac ox C4D R23
    Messages
    15
    Merci Aurety et lenogre, j'ai pu télécharger le fichier.
    je le regarde et vais aussi voir du côté du spline wrap qui semble être effectivement au autre moyen d'obtenir ce que je veux.

Discussions similaires

  1. Probleme avec l'outil influenceet les articulations
    Par lover-horse dans le forum Nouveaux membres
    Réponses: 3
    Dernier message: 07/04/2019, 21h10
  2. [Résolu] Petite présentation + Problème avec l'outil Bridge
    Par MrGladiatoR dans le forum Nouveaux membres
    Réponses: 3
    Dernier message: 01/09/2012, 15h02
  3. [Problème] Problème avec l'outil Spline bézier.
    Par Phlos dans le forum Nouveaux membres
    Réponses: 5
    Dernier message: 20/05/2012, 20h11
  4. problème de points avec l'outil couteau
    Par ennazus1 dans le forum Nouveaux membres
    Réponses: 3
    Dernier message: 28/02/2006, 09h32
  5. probleme avec l'outil polygonal
    Par ali13 dans le forum Général Cinema 4D
    Réponses: 2
    Dernier message: 15/06/2005, 10h47

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •  
Mediaworks - Logiciels 3D | Design Internet - Creation site internet